Ting Internet - Partial Outage - Memphis, TN

Incident Report for Ting Internet

Update

Our technicians are still working to complete the maintenance over run. We appreciate your patience while we work through these issues.

We do not have a firm ETA at this time, but will update when we do.
Posted Mar 30, 2026 - 12:44 EDT

Update

They are continuing to work through the maintenance over night and we will continue to update as new information becomes available.

Thank you for your patience.
Posted Mar 30, 2026 - 11:22 EDT

Update

Our technicians are still working to complete the maintenance over run. We appreciate your patience while we work through these issues.

We do not have a firm ETA at this time, but will update when we do.
Posted Mar 30, 2026 - 11:22 EDT

Update

They are still working on completing the maintenance. Please be patient as our field team continues the work to resolve any customers currently offline.

We thank you for that patience.
Posted Mar 30, 2026 - 09:43 EDT

Update

Estimated completion for maintenance is 8:30am local time.
Posted Mar 30, 2026 - 08:31 EDT

Identified

Thank you for your patience but we have confirmed that the ground team is still working on the maintenance from last night. Some customer will be impacted by that. Please be aware we are working on restoring service as quickly as possible and appreciate your patience.
Posted Mar 30, 2026 - 07:07 EDT

Update

Despite earlier reports of completion, scheduled maintenance is continuing for an estimated 2 more hours. We are working to restore full internet connectivity as quickly as possible and appreciate your continued patience. We apologize for any inconvenience this may have caused.
Posted Mar 30, 2026 - 07:06 EDT

Investigating

Following the completion of our scheduled maintenance earlier today, we are now experiencing an unforeseen internet outage in Memphis, Tennessee. We are working to get back online and appreciate your patience. Stay tuned for further updates. We apologize for any inconvenience this may have caused.
Posted Mar 30, 2026 - 06:42 EDT
This incident affects: Tennessee (Memphis).