Ting Internet - Partial Outage in Angier, NC.

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted May 06, 2026 - 19:51 EDT

Identified

We have identified damage to our mainline conduit and are actively working to restore service. Our technicians are repairing the affected lines, and service may begin to come back online shortly. Thanks for your patience.
Posted May 06, 2026 - 12:06 EDT

Investigating

We are currently investigating a service issue affecting a small number of customers in our Angier, NC market. We believe this may be related to nearby construction, and Ting technicians have been dispatched to investigate. We will provide updates as more information becomes available.
Posted May 06, 2026 - 09:02 EDT
This incident affected: North Carolina (Angiers, NC).