Ting Sanford - Power outage

Incident Report for Ting Internet

Resolved

This outage has been resolved and services have been restored.
Posted 2 months ago. Apr 08, 2025 - 07:45 EDT

Identified

Duke Energy is reporting power outages in the city and this may be impacting some of our services. We will continue to monitor the situation.
Posted 2 months ago. Apr 08, 2025 - 02:11 EDT
This incident affected: North Carolina (Sanford, NC).