Ting field crews have completed repairs, and we are now seeing the majority of affected customers back online. At this time, our teams are continuing to investigate a smaller number of customers who are still offline. We will continue to provide updates as more information becomes available. Thank you for your patience.
Posted May 28, 2026 - 11:52 EDT
Update
Ting Internet engineers remain actively engaged in restoration efforts in the field. At this time, we do not have an ETA for full restoration, as more extensive repair work is required than initially anticipated. We will continue to share updates as more information becomes available. Thank you for your patience.
Posted May 28, 2026 - 09:11 EDT
Update
Ting Internet engineers continue to work in the field to restore service to customers. The current Estimated Time to Repair is 2-3 hours. We will provide a further update before 9AM ET.
Posted May 28, 2026 - 07:57 EDT
Update
Ting Internet Engineers are on site continuing to work to resolve the extended maintenance window. The current Estimated Time to Repair is 3-4 hours. We will provide a further update before 8AM ET.
Posted May 28, 2026 - 06:54 EDT
Identified
The overnight maintenance in the Belvedere and Dunlora areas to accommodate a storm sewer project on Rio Rd is being extended for splicing to complete. Work remains underway at this time.
We will post an estimated time of completion as soon as possible. Thank you for your patience.
Posted May 28, 2026 - 05:58 EDT
This incident affects: Virginia (Charlottesville, VA).