Field Operations has confirmed that the damaged fiber has been successfully spliced and repaired. At this time, all previously offline services appear to be back online.
If you are still experiencing any issues, please contact us at 1-844-846-4994 so we can assist you with individual troubleshooting.
Posted May 20, 2025 - 08:21 EDT
Update
Due to the ongoing storm in Charlottesville, our workers are unable to safely complete repairs for customers tonight and will be back on Saturday morning to continue restoration. Thanks for your patience.
Posted May 16, 2025 - 17:54 EDT
Identified
Ting Internet engineers are on site at a fiber cut affecting customers on Shady Grove Ct near Lake Reynovia. Workers are determining next steps and we will provide an ETA to service restoration as soon as possible.
Posted May 16, 2025 - 17:35 EDT
This incident affected: Virginia (Charlottesville, VA).