Simply Bits- Ting, Tucson, AZ - Phone System issue
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Jun 27, 2024 - 14:26 EDT
Investigating
We are currently experiencing a Network wide issue that is affecting our Commercial customer's phone quality. Our phone Engineers are currently investigating the source of the issue. We apologize for the service interruption, and appreciate your patience as we work on a resolution.
Posted Jun 26, 2024 - 18:38 EDT
This incident affected: Arizona (Tucson).