Greenwood Village

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 21:44 EDT

Monitoring

We are aware of an issue that is affecting internet customers in Greenwood Village. If this is you please power cycle your ONT and Router, this should resolve the issue. If not, please call our support line at 844-894-4994.
Posted Apr 20, 2026 - 17:27 EDT

Identified

We are aware of an issue that is affecting internet customers in Greenwood Village. If this is you please power cycle your ONT and Router, this should resolve the issue. If not, please call our support line at 844-894-4994.
Posted Apr 20, 2026 - 16:56 EDT
This incident affected: Colorado (Greenwood Village, CO).