Simply Bits Minor Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Sep 28, 2025 - 13:48 EDT

Monitoring

This issue is resolved at this time. Thank you for your patience. We will monitor this throughout the day
Posted Sep 28, 2025 - 12:55 EDT

Investigating

We are experiencing a small outage in the Vail and SE Tucson areas affecting approximately 80 customers. Our technicians are in route but we do not have an ETA at this time. More updates to follow.
Posted Sep 28, 2025 - 09:18 EDT
This incident affected: Arizona (Tucson, Vail).