De Beque CO Outage - Investigating
Incident Report for Ting Internet
Resolved
This incident has now been resolved. If you are still continuing to have issues please call us at 844-846-4994.

Thank you.
Posted Jun 19, 2022 - 16:26 EDT
Investigating
We are currently investigating a loss of sudden connectivity in the De Beque, CO area. We will update as more information becomes available. We apologize for any inconvenience
Posted Jun 18, 2022 - 16:57 EDT
This incident affected: Colorado (De Beque, CO).