Customer Service Team - Phone System Issue
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Jun 10, 2022 - 11:00 EDT
Monitoring
Calls are routing correctly to Ting's customer service team again. We should be able to assist you with your question or concern if you call in for help. Thanks for your understanding.
Posted Jun 10, 2022 - 00:59 EDT
Identified
The phone system software that we use for our Customer Service team is currently experiencing problems with routing calls to Ting staff. We may not be able to answer your call until the issue is resolved. Feel free to use our Live Chat option at Ting.com/support or if it is not urgent, email us at help@ting.com

Thank you for your patience and understanding while this is looked into with our software vendor.
Posted Jun 09, 2022 - 23:39 EDT
This incident affected: Customer Support.