Sandpoint Idaho power outages

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted May 20, 2025 - 08:27 EDT

Identified

Sandpoint is experiencing some power outages at this time that may be affecting your service. Avista is working to restore power at this time.
Posted May 19, 2025 - 12:44 EDT
This incident affected: Idaho (Greater Sandpoint, ID, Ponderay, ID).