Small outage in Fuquay-Varina, North Carolina

Incident Report for Ting Internet

Resolved

We were able to identify the issue with the service and repair quickly.

Issue should now be considered resolved. Thank you for your patience.
Posted May 18, 2026 - 18:55 EDT

Investigating

We are currently investigating a small outage. Please stand by as we will update with further information as it becomes available.

Thank you for your patience.
Posted May 18, 2026 - 12:16 EDT
This incident affected: North Carolina (Fuquay-Varina, NC).