Ting Internet - Partial Outage in Holly Springs, NC.

Incident Report for Ting Internet

Identified

Ting Internet engineers have investigated and determined there has been damage to our fiber lines by a third party.. We are determining the scope of the repair and will advise of an ETA as soon as possible.
Posted Jul 17, 2026 - 14:11 EDT

Investigating

We are investigating a partial outage impacting service for some of our Holly Springs, NC customers. We will provide additional information as it becomes available.
Posted Jul 17, 2026 - 11:16 EDT
This incident affects: North Carolina (Holly Springs, NC).