Outage Centennial, CO

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 21:26 EDT

Monitoring

The remaining offline customers appear to be impacted by an ongoing power outage. Once power is fully restored, please power cycle your equipment if you are still experiencing issues. If you remain offline after performing a power cycle, please contact our support team at 1-844-846-4994
Posted Jul 06, 2026 - 20:23 EDT

Identified

The majority of our customer services are now back online. Our field teams remain on-site, actively working to resolve the issue for the remaining impacted customers. Thank you for your continued patience.
Posted Jul 06, 2026 - 18:55 EDT

Investigating

We are currently see customers service offline in Centennial, CO are investigating the issue
Posted Jul 06, 2026 - 17:10 EDT
This incident affected: Colorado (Centennial, CO).