Simply Bits - Douglas Arizona - Service Outage

Incident Report for Ting Internet

Identified

The cause of this issue has been isolated to a cable break for one of the main cables that provides internet to Douglas. We are investigating and Lumen, the owners of the impacted cable have technicians on site and are working to restore service as quickly as possible.
Posted Jul 22, 2026 - 09:57 EDT

Investigating

Simply Bits Internet engineers are investigating reports of an outage impacting service for customers in Douglas. We will post further information and next steps here as soon as it becomes available.
Posted Jul 22, 2026 - 05:36 EDT
This incident affects: Arizona (Douglas).