Ting Internet -Centennial,CO - Partial Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jul 26, 2026 - 21:50 EDT

Monitoring

Equipment has been replaced and services have been restored. We will be monitoring the connections closely to ensure there are no further issues. Thank you for your patience.
Posted Jul 26, 2026 - 21:08 EDT

Identified

We have identified the cause of the outage, and replacing equipment that has failed. Our field team is still working to resolve this, but has no ETA as of right now. We will provide more information as it becomes available
Posted Jul 26, 2026 - 20:17 EDT

Investigating

Ting Internet engineers are investigating reports of an outage impacting service for some customers in Centennial,CO. We will post further information and next steps here as soon as it becomes available.
Posted Jul 26, 2026 - 19:08 EDT
This incident affected: Colorado (Centennial, CO, Colorado Springs, CO, Glenwood Springs, CO).