Partial Outage - Grand Junction, CO

Incident Report for Ting Internet

Resolved

This incident will be taken down for duplicate purposes. Please see the latest update for more information. Thank you.
Posted Nov 24, 2025 - 11:25 EST

Identified

We have identified in the Grand Junction area the cause of some intermittent connectivity through our upstream vendor partner, Lumen and customers in this region may see service connectivity issues as a result. We will update once we have an update with our vendor partner on an estimated time of repair and resolution.
Posted Nov 24, 2025 - 11:23 EST
This incident affected: Colorado (Grand Junction, CO).