Ting Internet - Centennial- Partial Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Nov 02, 2025 - 15:47 EST

Monitoring

Service has been restored for the majority of affected areas. If you're still experiencing connectivity problems, please try rebooting your router and fiber ONT. If the issue persists, feel free to contact our support team at 1-844-846-4994 for further assistance.
Posted Nov 02, 2025 - 13:40 EST

Investigating

Ting Internet engineers are investigating reports of an outage impacting service for some customers in Centennial, CO . We will post further information and next steps here as soon as it becomes available.
Posted Nov 02, 2025 - 13:26 EST
This incident affected: Colorado (Centennial, CO).