SimplyBits - Piano Mountain Area Outage - Tucson, AZ

Incident Report for Ting Internet

Resolved

Power was restored to this site and all customers should have internet access restored. Please power cycle your radio and router if you are not online and your service should come back online automatically
Posted Mar 02, 2026 - 10:00 EST

Update

Our infrastructure team is headed to the access tower site to investigate the issue. We believe it to be possibly power related, but will update as we find out more when on site.
Posted Mar 01, 2026 - 18:10 EST

Investigating

We are currently investigating an issue with our access tower in the Piano Mountain area. We will update once we have further information and we have our infrastructure team out to take a look.
Posted Mar 01, 2026 - 17:13 EST
This incident affected: Arizona (Tucson).