Internet Service Outage - Farmington, NM

Incident Report for Ting Internet

Resolved

A fix is in place, and we have effectively resolved the issue. At this time we continue to monitor the link that was brought down for any further issues.
Posted Sep 23, 2025 - 12:59 EDT

Update

There are now technicians on site to investigate and troubleshoot the issue.
Posted Sep 22, 2025 - 17:22 EDT

Investigating

We are currently investigating a service outage affecting Internet customers in Farmington, NM. This outage is affecting several clients downtown and we are working to identify and resolve the issue causing it but do not have any ETA for when this will be restored yet at this time.
Posted Sep 22, 2025 - 16:49 EDT
This incident affected: New Mexico (Farmington, NM).