Splice work has been completed and we are seeing the majority of the impacted customers recover and online. If you are still unable to get online please reach out to us for individual troubleshooting. We will continue to monitor for any residual issues for the remainder of the day.
Posted Jun 28, 2026 - 13:05 EDT
Identified
Our field team has identified two points of fiber damage, they are assessing the needs to prepare to deploy a repair to restore services impacted as soon as possible. We currently do not have an estimated time of repair due to the extent of the damage and work needed, we will provide further updates as points of repair are completed and an ETA as soon as one becomes available.
Posted Jun 28, 2026 - 10:52 EDT
Investigating
We are currently investigating a service issue impacting a group of enterprise customers in Wake Forest, NC. Our field technicians are en route to investigate, and we will provide updates as more information becomes available.
Posted Jun 28, 2026 - 06:26 EDT
This incident affects: North Carolina (Wake Forest, NC).