Outage in Angiers North Carolina

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 19:48 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2026 - 18:33 EDT

Identified

We've identified the source of the damage and will begin preparing the fiber for repair shortly. We'll provide another update once splicing is underway. Current estimated time of restoration is 8:30 or sooner.
Posted Apr 28, 2026 - 16:44 EDT

Investigating

We're seeing a small outage in Angiers at this time affecting roughly 6-10 customers. We are investigating the cause and will update when we have more information.
Posted Apr 28, 2026 - 15:27 EDT
This incident affected: North Carolina (Angiers, NC).