Ting Internet - Holly Springs, NC - Scheduled Maintenance

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Sep 24, 2026 - 05:46 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 24, 2026 - 05:46 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 24, 2026 - 03:09 EDT

Identified

In Holly Springs, NC, Ting Internet engineers are performing the maintenance on our network.

As a result, Ting Internet services for some customers is briefly disrupted and then service will be automatically restored.

We'll be working hard to ensure the downtime is as minimal as possible. If you have any questions, please contact us at 1-844-846-4994 (Available 24/7) or visit https://ting.com/support
Posted Sep 24, 2026 - 00:17 EDT
This incident affected: North Carolina (Angiers, NC, Holly Springs, NC).