Ting Internet - degraded performance in Rifle & Grand Junction

Incident Report for Ting Internet

Update

We are still experiencing degraded service and intermittent connectivity issues affecting some customers in the Rifle/Grand Junction area. We have escalated a ticket to the upstream network partner that is the root cause of this problem. We will provide further updates as more becomes available to us.
Posted Nov 26, 2025 - 10:47 EST

Identified

We are currently experiencing degraded service and intermittent connectivity issues affecting some customers in the Rifle/Grand Junction area. Our network partner is working to fix this issue, and we will provide updates as more information becomes available.
Posted Nov 24, 2025 - 11:20 EST
This incident affects: Colorado (Grand Junction, CO, Rifle, CO).