We have restored our access points at Dove Mountain and customers are coming back online. If you are still experiencing issues, please restart the power adapter for our dish, and reach out to our support team if your internet connection hasn't been restored. Thank you!
Posted Jul 12, 2026 - 16:26 EDT
Update
Our infrastructure team is on site at Dove Mountain tower continuing to investigate the issues with our access points. Thank you for your patience!
Posted Jul 12, 2026 - 13:31 EDT
Investigating
After a monsoon last night, we've had reports from some customers that service is offline. Most reports are coming from customers connected to our Dove Mountain tower. All customers who would connect to this tower are currently offline. We are currently investigating the access points of this tower is hopes of getting services restored as soon as possible. We're also monitoring the status of power restoration in the nearby area.