Power has been restored in the area affected. All but a few customer should be back online, if you are not, please try power-cycling your equipment (Ting ONT modem & router) to see if that helps, and if not, please call our support line at 844-846-4994.
Posted Jul 05, 2025 - 08:58 EDT
Update
Although Dominion Energy is still dealing with power issues in the area, some of the power to our impacted equipment has now been restored. We've also setup a generator to provide temporary power to areas which have not. That being said, not all but the majority of our impacted customers should be back online for now. If you are still without service, please try power-cycling your equipment (Ting ONT modem & router) to see if that helps, and if not, then it means your service is still impacted by the power outages in the area but we expect those to be resolved soon. We will provide further updates here as they become available.
Posted Jul 04, 2025 - 20:05 EDT
Identified
Ting Internet engineers are on site with Dominion Energy at a location where a tree has fallen. Power lines have been severed which has caused a power outage in the North Downtown and Fry's Spring including Ting equipment servicing the area. We will provide an ETA once available, pending power restoration to the area. Thank you for your patience.
Posted Jul 04, 2025 - 18:16 EDT
Investigating
Ting Internet engineers are investigating reports of an outage affecting some customers in Charlottesville, VA. We will post further information as soon as possible.
Posted Jul 04, 2025 - 17:51 EDT
This incident affected: Virginia (Charlottesville, VA).