SimplyBits - Internet Stability and Speed Issues

Incident Report for Ting Internet

Resolved

We have determined that this was caused by a memory/CPU spike on one of our infrastructure routers. After further monitoring, we have confirmed this issue has been resolved.
Posted Mar 20, 2026 - 10:55 EDT

Identified

Internet stability seems to have returned although some customers are still reporting issues with speeds which we are troubleshooting individually.

Packet loss seemed to have occurred at various point to point links in multiple locations. Our engineers are still investigating the root cause, but internet should be working!
Posted Mar 19, 2026 - 19:50 EDT

Investigating

We are currently investigating multiple reports of internet stability and speed issues that appear to have affected multiple customers across the city of Tucson and surrounding areas. We will be updating this status page as soon as we know more. Thank you for your patience!
Posted Mar 19, 2026 - 19:19 EDT
This incident affected: Arizona (Tucson, Catalina, Amado, Douglas, Green Valley, Marana, Mt. Lemmon, Nogales, Oracle, Oro Valley, Rio Rico, Sahuarita, San Manuel, Tubac, Vail).