Holly Springs Partial Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jun 08, 2025 - 08:17 EDT

Monitoring

Repairs have been completed. We are seeing service restored to Ting Internet customers in Holly Springs. If you are experiencing an issue at this time, please first reboot your router and if you are having any further issues, contact our Support team at 1-844-846-4994.
Posted Jun 07, 2025 - 20:14 EDT

Update

We are currently seeing a partial outage in Holly Springs, North Carolina, that is affecting roughly 70 customers. How technicians have been notified and will investigate. No ETA at this time.
Posted Jun 07, 2025 - 17:20 EDT

Update

We are continuing to investigate this issue.
Posted Jun 07, 2025 - 16:46 EDT

Investigating

We are currently seeing a partial outage in Holly Springs, North Carolina, that is affecting roughly 70 customers. How technicians have been notified and will investigate. No ETA at this time.
Posted Jun 07, 2025 - 16:46 EDT
This incident affected: North Carolina (Holly Springs, NC).