Service Outage - Corona De Tucson

Incident Report for Ting Internet

Resolved

This has now been resolved. Thank you,
Posted Oct 07, 2025 - 18:35 EDT

Identified

Multiple customers in Corona De Tucson are out of service at this time, and we have identified an equipment issue at the Corona pole tower as the cause. We have dispatched a technician to attend the tower on site and troubleshoot the issue, and they are en route now. We do not have an ETA when to expect service to be restored.
Posted Oct 07, 2025 - 17:43 EDT
This incident affected: Arizona (Vail).