500 errors on some pages of Ting.com

Incident Report for Ting Internet

Identified

We have identified some of the issues and continue to work through them and will restore service completely as soon as possible.

Please stand by as we continue to perform maintenance.

Thank you for your patience
Posted Apr 14, 2026 - 13:31 EDT

Investigating

We have identified limited instances of "http 500" errors occurring on the "Contact us" and "Help" pages of [Ting.com](http://Ting.com).

Please stand by as we work to resolve this.

We will post more information as it becomes available. Thank you for your patience
Posted Apr 14, 2026 - 10:41 EDT
This incident affects: Ting Website, Shop & Your Account.