Splicing work has been completed, and all services are back online. Most services were restored as of an hour ago, but a few remaining circuits took additional time to remedy. If you are still seeing issues with your internet service, give us a call at 1-844-846-4994 so we can proceed with individual troubleshooting.
Posted Jan 21, 2026 - 19:50 EST
Update
Splicing work is still in progress. Many services have recovered but may go down again temporarily as we work to finish the repairs. Once we have full recovery it will state so here.
Posted Jan 21, 2026 - 17:09 EST
Update
Fiber splicing and repair has begun, with a current estimated time of repair of 6:00 pm. Several fiber drops were damaged and some lines may need to be re-blown; that estimate includes the work regarding those.
Posted Jan 21, 2026 - 15:58 EST
Update
We are continuing to work on a fix for this issue.
Posted Jan 21, 2026 - 15:13 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 21, 2026 - 14:11 EST
Investigating
We are investigating suspected fiber damage affecting homes on and near near Cala Lilly Ln / Torry Hill Ct in Wake Forest, North Carolina. As of this writing Ting team members are en route to survey the specifics of the damage then begin repair work ASAP. An ETR is not yet available as it depends on the severity and location of the strike. More information will be posted here as soon as it becomes available from our field team.
Posted Jan 21, 2026 - 13:05 EST
This incident affected: North Carolina (Wake Forest, NC).