The scheduled maintenance has been extended by another half hour. We will update once completed
Posted Dec 12, 2025 - 10:30 EST
Update
Due to unexpected delays, the maintenance window has been extended until 7:00am PT. Thank you for your patience as we work through the maintenance to restore full service.
Posted Dec 12, 2025 - 08:28 EST
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Dec 12, 2025 - 06:35 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 12, 2025 - 05:23 EST
Scheduled
Scheduled maintenance for Ting Internet – Laguna Woods Village, CA has exceeded the planned window due to unexpected delays. Our engineering team is still actively working to complete the remaining tasks, and customers in the area may experience service interruptions during this time. The new estimated completion time for this maintenance is 6:00 AM PT. We appreciate your patience as we work to restore full service.
Posted Dec 12, 2025 - 05:22 EST
This scheduled maintenance affected: California (Laguna Woods Village).