Possible power issues in Holy Springs NC

Incident Report for Ting Internet

Resolved

This has been confirmed to be power related. Closing this status.
Posted Jun 27, 2026 - 15:52 EDT

Investigating

We're seeing a large number of customers service affected in Holly Springs NC but it is looking like this is power related. We will keep an eye for any changes.
Posted Jun 27, 2026 - 15:18 EDT
This incident affected: North Carolina (Holly Springs, NC).