This issue should now be resolved and all customers affected back online. We will monitor this for hour or so.
Posted Oct 27, 2025 - 15:46 EDT
Update
Most of the customers affected by this emergency maintenance are back online at this time. The remaining 15 or so should be back in the next 30 minutes or less. We will continue monitoring the issue.
Posted Oct 27, 2025 - 15:00 EDT
Update
We are performing a quick emergency maintenance in Charlottesville VA that is taking longer than expected. Some equipment will need to be replaced. We are currently working on this issue and have no ETA at this time.
We appreciate your patience.
Posted Oct 27, 2025 - 14:41 EDT
Identified
We are performing a quick emergency maintenance in Charlottesville VA that will affect approximately 75 customers. Any service interruptions shouldn't last for more than 10-15 minutes.
We apologize for this late notice.
Posted Oct 27, 2025 - 14:19 EDT
This incident affected: Virginia (Charlottesville, VA).