Internet outage in Wake Forest, NC

Incident Report for Ting Internet

Identified

We have confirmed that the damage is localized to the same transport cable that was impacted last night. Construction activity in the area resulted in additional damage to the cable.

Our vendor has completed the required civil construction work today, which will allow us to proceed with the permanent fiber repair tonight. We currently expect the repair to be completed by 11:00 PM tonight. We will continue to provide updates as the work progresses.
Posted Sep 25, 2026 - 17:06 EDT

Investigating

Some customers in Wake Forest, NC are without internet service right now, and our engineers are already on it. We'll post an update here as soon as we have one.

Customers in the affected area don't need to restart anything — service will come back on its own once the fix is in. We appreciate everyone's patience while we work on this.
Posted Sep 25, 2026 - 16:17 EDT