Partial outage in Culver City, California

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Sep 22, 2025 - 18:04 EDT

Monitoring

This issue was the result of a planned power maintenance by Edison. We will monitor the status of these connections but will hove no updates or ETR until we hear from the power company.
Posted Sep 22, 2025 - 14:33 EDT

Investigating

We are currently investigating a group of customers that appeared to be knocked offline around 12 EST. Please stay tuned for further updates as we investigate this outage.

Thank you for your patience.
Posted Sep 22, 2025 - 13:40 EDT
This incident affected: California (Culver City, CA).