Some customers still down after maintenance

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted May 14, 2026 - 14:45 EDT

Monitoring

A fix has been implemented, and we are seeing connections restored at this time. If you are still experiencing problems, kindly reboot your router and fiber ONT. If the issue persists, please contact us at 1-844-846-4994 for further individual troubleshooting.
Posted May 14, 2026 - 10:20 EDT

Identified

We continue to work through customers impacted and see them coming back online. We will further update here once complete.
Posted May 14, 2026 - 09:24 EDT

Investigating

After last night's maintenance, we are seeing a small subset of customers (less than 50) still offline. Our engineers are currently working through extended issues and expect to have customers back online in the next 2 hours. Thank you for your patience.
Posted May 14, 2026 - 08:09 EDT
This incident affected: Virginia (Charlottesville, VA).