SimplyBits - Some Customers in Marana, AZ Unable To Connect To Internet

Incident Report for Ting Internet

Resolved

Our engineering team was able to pinpoint the cause of the issue and resolve it, all affected customers on this sector should now be able to connect to the internet. If there are still any issues, please perform a restart of your router or call our support line if you are still unable to connect afterwards. Thank you!
Posted Aug 13, 2026 - 23:59 EDT

Investigating

We have noticed an issue with some customers in Marana, AZ off of our Triangle Y tower being unable to connect to the internet. All equipment is online so we are investigating why traffic isn't passing to the 8 customers affected.
Posted Aug 13, 2026 - 23:28 EDT
This incident affected: Arizona (Marana).