Ting Internet - Culver City, CA (Heather Village) - Partial Outage

Incident Report for Ting Internet

Update

We are currently waiting for the work with electrical to be completed. They have reported that the work being done will continue to 6 PM PST.

We will continue to monitor the electrical upgrade by SCE. We will update as more information becomes available.

Thank you for your patience.
Posted Feb 11, 2026 - 15:58 EST

Identified

Electrical power has been shut off to parts of the Culver City (Heather Village) area by SCE while equipment upgrades are being done. Estimated power restoration by SCE is 6:00PM PT.
Posted Feb 11, 2026 - 13:09 EST

Investigating

Ting Internet engineers are investigating reports of an outage impacting service for some customers at Heather Village in Culver City, CA. We will post further information and next steps here as soon as it becomes available.
Posted Feb 11, 2026 - 12:49 EST
This incident affects: California (Culver City, CA).