Ting Internet - Charlottesville, VA - Partial Outage

Incident Report for Ting Internet

Monitoring

Service has been restored but continue to monitor the recent fix. If you still have trouble, please restart your equipment. If the issue persists, please reach out to support at 1-844-846-4994.
Posted Jul 26, 2026 - 15:38 EDT

Investigating

Ting Internet engineers are investigating reports of an outage impacting service for some customers in Charlottesville, VA. We will post further information and next steps here as soon as it becomes available.
Posted Jul 26, 2026 - 13:28 EDT
This incident affects: Virginia (Charlottesville, VA).