Greenwood Village CO

Incident Report for Ting Internet

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2026 - 17:17 EDT

Investigating

We are seeing some issues in Greenwood Village in Colorado where customers may be affected. We are looking into the issue to determine a cause and will update when we have more. No ETA at this time
Posted Sep 12, 2026 - 16:39 EDT
This incident affects: Colorado (Greenwood Village, CO).