At this time, we’re seeing customer services gradually being restored as power returns to the area. We will continue to actively monitor the situation
Posted Feb 11, 2026 - 10:24 EST
Identified
We continue to monitor the situation, as a significant number of customers remain affected by the ongoing power outage in the area.
Posted Feb 11, 2026 - 08:45 EST
Update
Ting Internet engineers are investigating reports of an outage impacting service for some customers in Rolesville, NC. As power is still in the process of being restored in the area we will investigate customers still down and continue to work on those customers affected.
Thank you for your patience as we continue to investigate into this.
Posted Feb 10, 2026 - 21:43 EST
Investigating
Ting Internet engineers are investigating reports of an outage impacting service for some customers in Rolesville, NC. As power is restored in the area we will investigate customers still down and continue to work on customers still down.
Thank you for your patience as we continue to investigate into this.
Posted Feb 10, 2026 - 18:25 EST
This incident affected: North Carolina (Rolesville, NC).