SimplyBits - Fax Services

Incident Report for Ting Internet

Resolved

We learned that our network partner resolved this overnight. All fax services should be up and running, but if you are encountering any issues, please feel free to contact Support!
Posted Aug 20, 2026 - 11:14 EDT

Identified

We have discovered an issue with our Fax PRI, which we have reached out to our network partner to help resolve. Our engineering team has tried to re-route fax services in hopes of restoring it while we wait on the fix, but this may not have restored it fully.
Posted Aug 20, 2026 - 11:08 EDT
This incident affected: Arizona (Tucson, Catalina, Amado, Douglas, Green Valley, Marana, Mt. Lemmon, Nogales, Oracle, Oro Valley, Rio Rico, Sahuarita, San Manuel, Tubac, Vail).