Rio Rico Service Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Sep 27, 2025 - 21:22 EDT

Monitoring

Services have been restored. If you are seeing any issues at this time, please contact our Support team at 1-844-846-4994.
Posted Sep 27, 2025 - 14:11 EDT

Investigating

We are currently investigating a service outage affecting multiple customers in Rio Rico, and have network engineers working with our field technician to dispatch on site, to investigate at the tower where the equipment for our link is down.
Posted Sep 27, 2025 - 10:55 EDT
This incident affected: Arizona (Rio Rico).