Simply Bits: Wide Range Outage in Tucson, AZ (Country Club and surrounding areas)
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 07:00 EST
Investigating
We are currently experiencing a Wide Spread outage affecting many of our Simply Bits customers. The issue has been identified and our Infrastructure Team has been dispatched and are en Route for repair. We apologize for the inconvenience, and will continue to update this site when we have an estimated time of resolution.
Posted Nov 13, 2023 - 15:34 EST
This incident affected: Arizona (Tucson).