Wake Forest NC, Alba Rose area.

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 16:50 EDT

Monitoring

Everything should be back up and working. We will continue to monitor the maintenance results.

Thank you for your patience.
Posted Aug 26, 2026 - 10:44 EDT

Identified

We are performing some emergency Maintenance in the Alba Rose area of Wake Forest NC this morning that may affect up to 30 customers. We will post updates on progress as we can.
Posted Aug 26, 2026 - 09:44 EDT
This incident affected: North Carolina (Wake Forest, NC).