Partial Outage Culver City California in the area of 9696 CULVER BLVD

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 12:00 EST

Monitoring

Repairs have been completed, and we are seeing connections restored at this time. We will be monitoring the connections closely to ensure there are no further issues. Thank you for your patience.
Posted Mar 03, 2026 - 08:29 EST

Update

We are continuing to work on a fix for this issue.
Posted Mar 02, 2026 - 23:07 EST

Identified

Our field team has identified fiber damage at the building entrance. They are currently gathering materials and preparing to implement repairs.
Posted Mar 02, 2026 - 20:55 EST

Update

We are continuing to investigate this issue.
Posted Mar 02, 2026 - 20:34 EST

Investigating

We are currently investigating this issue.
Posted Mar 02, 2026 - 19:10 EST
This incident affected: California (Culver City, CA).