SimplyBits - Tucson - Partial VoIP Outage

Incident Report for Ting Internet

Monitoring

The PBX server has been restored. We will keep this status up for monitoring through the day to ensure no further issues come up. If you are still having issues with individual phones, please reboot them from their power source to re-register.
Posted Nov 07, 2025 - 10:58 EST

Identified

Our engineers have identified a PBX issue with our VoIP services in Tucson, AZ. They are actively working on getting this restored, but do not have an estimate time of restoral at this time. We will update this as more information is available. Thank you for your patience!
Posted Nov 07, 2025 - 10:47 EST
This incident affects: Arizona (Tucson).