At this time we have 3 buildings still offline in the Eagles Landing apartment complex, and engineers are on site working to restore service there.
Part of the repair caused a number of services in Jefferson Ridge apartments to drop offline briefly, and if you are still offline in that complex please power cycle your equipment by unplugging the ONT from power for 30 seconds and plugging it back in. Service has been restored in all cases so far once that has been done.
Posted Jul 01, 2026 - 13:22 EDT
Investigating
We are aware that a small number of customers remain offline following the scheduled overnight maintenance in Charlottesville, VA. Our field crews are still on site and are working as quickly as possible to restore service to all remaining affected customers. Thank you for your patience.
Posted Jul 01, 2026 - 08:25 EDT
This incident affects: Virginia (Charlottesville, VA).