Outage in Greenwood Village, CO

Incident Report for Ting Internet

Resolved

Currently looks like the issue has been resolved and customers are now back online.

Thank you for your understanding while we were able to get service restored.
Posted Nov 24, 2025 - 07:48 EST

Identified

We are currently looking to resolve issues in the nearby area that caused the outage.

Please stand by while we implement a fix and more information becomes available.
Posted Nov 24, 2025 - 07:36 EST

Investigating

We are currently investigating an outage impacting Greenwood Village, CO where some customers appear to be offline.

Please stand by for us to post updates as more information becomes available.
Posted Nov 24, 2025 - 04:24 EST
This incident affected: Colorado (Greenwood Village, CO).